Documentation

Eclipse plug-in

This plug-in integrates JFormDesigner into Eclipse and other Eclipse based IDEs.

Benefits

Using this plug-in has following benefits compared to JFormDesigner stand-alone edition:

  • Fully integrated as editor for JFormDesigner .jfd files. Create and design forms within Eclipse. No need to switch between applications.
  • Uses the source folders and classpath of the current Eclipse project. No need to specify them twice.
  • The Java code generator updates the .java file in-memory on each change in the designer. You can design forms and edit its source code without the need to save them (as necessary when using JFormDesigner stand-alone edition).
  • Folding of generated GUI code in Java editor.
  • Go to event handler method in Java editor.
  • Two-way synchronization of localized strings in designer and in properties file editors. Changing localized strings in the designer immediately updates the .properties file in-memory and changing the .properties file updates the designer.
  • Copy needed libraries (JGoodies Forms, TableLayout, etc) to the project and add them to the classpath of the current Eclipse project. Optionally include source code and javadoc.
  • Integrated with Eclipse's Version Control Systems.
  • Integrated into refactoring: Copy, rename, move or delete .jfd files when coping, renaming, moving or deleting .java files.

User interface

The screenshot below shows the Eclipse main window editing a JFormDesigner form. JFormDesigner adds the menu Form to the main menu, which is only visible if a JFormDesigner form editor is active.

Eclipse main window

A JFormDesigner editor consists of:

  • Toolbar: Located at top of the editor area.
  • Palette: Located at the left side.
  • Design View: Located at the center.
  • Structure View: Located in Eclipse's Outline view.
  • Properties View: Located in Eclipse's Properties view.
  • Bindings View: Located below the Design view. This view is not visible by default. Click the Show Bindings View button () in the toolbar to make is visible.
  • Error Log View: Automatically opens on errors in a view at the bottom.

Creating new forms

To create a new form, click the New JFormDesigner Form () button in the Eclipse toolbar. You can also use Ctrl+Shift+V (Mac: Shift+Command+V).

New Form

You can also create new forms in Eclipse's Package Explorer view. First select the destination package or folder, then invoke Eclipse's New command and select Other, which opens Eclipse's New dialog. Then choose JFormDesigner Form from the list of wizards and click Next to proceed.

New Form Dialog

If JFormDesigner Form is in the New sub menu, you can choose it directly without the need to open Eclipse's New dialog.

New Form Menu

In the New JFormDesigner Form dialog, enter the form name (which is also used as class name), choose a superclass, a layout manager and set localization options.

Open forms for editing

You can open existing forms the same way as opening any other file in Eclipse. Locate it in Eclipse's Package Explorer view and double-click it.

Go to Java code / Go to form

JFormDesigner adds a button to Eclipse's main toolbar that enables you to switch quickly from a JFormDesigner form editor to its Java editor and vice versa. If a form editor is active, then the button is named Go to Java code (). If a Java editor is active, then it is named Go to JFormDesigner form (). You can also use Ctrl+Shift+D (Mac: Shift+Command+D).

Go to Java code   Go to form

Code folding

To move the generated code out of the way, JFormDesigner folds it in the Java editor.

Code folding

Convert NetBeans, IntelliJ IDEA and Abeille forms

You can convert existing NetBeans, IntelliJ IDEA and Abeille forms to JFormDesigner forms. Right-click on the form file (or any container) and select Convert to JFormDesigner Form.

Convert forms

When converting an IntelliJ IDEA form, JFormDesigner inserts its own generated GUI code into the existing Java class and removes IntelliJ IDEA's GUI code.

Preferences

The JFormDesigner preferences are fully integrated into the Eclipse preferences dialog. Select Window > Preferences from the menu to open it and then expand the node "JFormDesigner" in the tree. See Preferences for details.

You can also set project specific settings in the Eclipse project dialog. Select Project > Properties from the menu to open it and then expand the node "JFormDesigner" in the tree. See Preferences for details.

Keyboard shortcuts

You can assign shortcut keys to some JFormDesigner commands in Eclipse's keys preferences. Select Window > Preferences > General > Keys to open it. Search for "JFormDesigner" to find JFormDesigner commands.