Download Archive

Here you can download older versions of JFormDesigner. But we recommend using the current version.

JFormDesigner 5.2

IDE plug-ins

Eclipse

3.2 - 3.8, 4.0 - 4.6

Version: 5.2.5
Size: 12 MB
Date: 2016-11-04

Installation Instructions

NetBeans

7.0 - 8.2

Version: 5.2.5
Size: 7 MB
Date: 2016-11-04

Download

Installation Instructions

IntelliJ IDEA

9 - 2016.3

Version: 5.2.5.1
Size: 12 MB
Date: 2016-12-04

Download

Installation Instructions

JDeveloper

11g R2 - 12c

Version: 5.2.5
Size: 11 MB
Date: 2016-11-04

Download

Installation Instructions

JBuilder

2006

Version: 5.2.5
Size: 11 MB
Date: 2016-11-04

Download

Installation Instructions

Stand-alone & Documentation

Windows

with JRE

Version: 5.2.5
Size: 31 MB
Date: 2016-11-04

Download

Installation Instructions

Mac OS X

Version: 5.2.5
Size: 12 MB
Date: 2016-11-04

Download

Installation Instructions

Linux

Version: 5.2.5
Size: 11 MB
Date: 2016-11-04

Download

Installation Instructions

Documentation

Version: 5.2
Size: 3 MB
Date: 2014-05-18

Download

Customer information: JFormDesigner 5.2 is free of charge for existing customers if the "Free updates until" date of your license key is 2012-09-01 or later. Upgrades are available here.

System Requirements

Oracle/Sun Java SE Runtime Environment (JRE) 5, 6, 7 or 8. Latest Java 8 is recommended.

  • Eclipse plug-in: Eclipse 3.2 - 3.8, 4.0 - 4.6; other Eclipse based Java IDEs (e.g. JBuilder 2007+ or IBM RAD running on Oracle/Sun JRE); Mac OS X: Java SE 5.0 Release 5 (1.5.0_07) or later required, (Java 7u25 and older Java 7 releases are not supported on Mac OS X), Eclipse 3.3 and 3.3.1 are not supported on Mac OS X because of Eclipse Bug 199020
  • NetBeans plug-in: NetBeans 7.0 - 8.2
  • IntelliJ IDEA plug-in: IntelliJ IDEA 9 - 2016.3
  • JDeveloper plug-in: JDeveloper 11g Release 2 (11.1.2) or 12c (12.1.x - 12.2.x)
  • JBuilder plug-in: JBuilder 2006 (for JBuilder 2007+ use the Eclipse plug-in)

JFormDesigner 5.1

This version is no longer maintained.

IDE plug-ins

Eclipse

3.2 - 3.8, 4.0 - 4.3

Version: 5.1.3.3
Size: 11 MB
Date: 2014-09-09

NetBeans

7.0 - 8.0

Version: 5.1.3.2
Size: 7 MB
Date: 2014-05-26

Download

IntelliJ IDEA

8.0 - 13.1

Version: 5.1.3
Size: 11 MB
Date: 2014-05-12

Download

JBuilder

2006

Version: 5.1.3
Size: 10 MB
Date: 2014-05-12

Download

Stand-alone & Documentation

Windows

with JRE

Version: 5.1.3
Size: 36 MB
Date: 2014-05-12

Download

Mac OS X

Version: 5.1.3
Size: 12 MB
Date: 2014-05-12

Download

Linux

Version: 5.1.3
Size: 11 MB
Date: 2014-05-12

Download

Documentation

Version: 5.1
Size: 3 MB
Date: 2012-04-30

Download

Customer information: JFormDesigner 5.1 is free of charge for existing customers if the "Free updates until" date of your license key is 2011-07-26 or later. Upgrades are available here.

System Requirements

Sun/Oracle Java SE Runtime Environment (JRE) 5, 6 or 7. Latest Java 7 is recommended.

  • Eclipse plug-in: Eclipse 3.2 - 3.8, 4.0 - 4.3; other Eclipse based Java IDEs (e.g. JBuilder 2007+ or IBM RAD running on Sun/Oracle JRE); Mac OS X: Java SE 5.0 Release 5 (1.5.0_07 or later) or Java 6 or JDK 7 Developer Preview (1.7.0_12-ea or later) required (Java 7u25 and older are not supported on Mac OS X), Eclipse 3.3 and 3.3.1 are not supported on Mac OS X because of Eclipse Bug 199020
  • NetBeans plug-in: NetBeans 7.0 - 8.0
  • IntelliJ IDEA plug-in: IntelliJ IDEA 8.0 - 13.1
  • JBuilder plug-in: JBuilder 2006 (for JBuilder 2007+ use the Eclipse plug-in)

JFormDesigner 5

This version is no longer maintained.

IDE plug-ins Version Size Date
Eclipse (3.2 - 3.7) 5.0.4 11 MB 2012-04-12
Eclipse Archived Update Site 5.0.4 11 MB 2012-04-12
IntelliJ IDEA (8.0 - 11.1) 5.0.4.1 10 MB 2012-04-25
JBuilder (2006) 5.0.4 10 MB 2012-04-12
Stand-alone      
Windows Setup 5.0.4 10 MB 2012-04-12
Windows Setup with JRE 6 (Update 31) 5.0.4 24 MB 2012-04-12
Mac OS X 5.0.4 11 MB 2012-04-12
Linux and other platforms 5.0.4 11 MB 2012-04-12
Documentation      
Printable documentation (PDF) 5.0 3 MB 2011-04-19

Customer information: JFormDesigner 5 is free of charge for existing customers if the "Free updates until" date of your license key is 2010-01-01 or later. Upgrades are available here.

System Requirements

Sun/Oracle Java SE Runtime Environment (JRE) 5, 6 or 7.

  • Eclipse plug-in: Eclipse 3.2 - 3.7; other Eclipse based Java IDEs (e.g. JBuilder 2007+ or IBM RAD running on Sun/Oracle JRE); Mac OS X: Java SE 5.0 Release 5 (1.5.0_07 or later) or Java 6 required (Java 7 and later are not supported), Eclipse 3.3 and 3.3.1 are not supported on Mac OS X because of Eclipse Bug 199020
  • IntelliJ IDEA plug-in: IntelliJ IDEA 8.0 - 11.1
  • JBuilder plug-in: JBuilder 2006 (for JBuilder 2007+ use the Eclipse plug-in)