Documentation

Menus

You can invoke most commands from the main menu (at the top of the main frame) and the various context (right-click) menus.

Main Menu

The main menu is displayed at the top of the JFormDesigner main window of the stand-alone edition.

Main Menu

File menu
New Project New Project Creates a new project.
Open Project Open Project Opens an existing project.
Reopen Project Displays a submenu of previously opened projects. Select a project to open it.
Project Properties Project Properties Displays the project properties.
Close Project Closes the active project.
New Form New Form Creates a new form.
Open Form Open Form Opens an existing form.
Reopen Form Displays a submenu of previously opened forms. Select a form to open it.
Close Closes the active form.
Close All Closes all open forms.
Save Save Saves the active form and generates the Java source code for the form (if Java Code Generation is enabled in the Preferences).
Save As Save As Saves the active form under another file name or location and generates the Java source code for the form (if Java Code Generation is enabled in the Preferences).
Save All Save All Saves all open forms and generates the Java source code for the forms (if Java Code Generation is enabled in the Preferences).
Import Import Imports NetBeans or IntelliJ IDEA form files and creates new JFormDesigner forms. Use File > Save to save the new form in the same folder as the original form file. This also updates the .java file.
Exit Exits JFormDesigner. Mac: this item is in the JFormDesigner application menu.
 
Edit menu
Undo Undo Reverses your most recent editing action.
Redo Redo Re-applies the editing action that has most recently been reversed by the Undo action.
Cut Cut Cuts the selected components to the clipboard.
Copy Copy Copies the selected components to the clipboard.
Paste Paste Pastes the components in the clipboard to the selected container of the active form.
Rename Renames the selected component.
Delete Delete Deletes the selected components.
 
View menu
Refresh Designer Refresh Designer Refresh the Design view of the active form. Reloads all classes used by the form and recreates the form preview shown in the Design view. You can use this command, if you changed the code of a component used in the form to reload the component classes. But usually this is not necessary because JFormDesigner automatically reloads component classes.
Classic Layout Classic Layout Shows Properties view below Structure view.
Wide Layout Wide Layout Shows Properties and Structure views side by side.
 
Form menu
Test Form Test Form Tests the active form. Creates live instances of the form in a new window. You can close that window by pressing the Esc key when the window has the focus. If your form contains more than one top-level component, use the drop-down menu in the toolbar to test another component.
Localize Localize Edit localization settings, resource bundle strings, create new locales or delete locales.
New Locale New Locale Creates a new locale.
Delete Locale Delete Locale Deletes an existing locale.
Externalize Strings Externalize Strings Moves strings to a resource bundle for localization. Use this command to start localizing existing forms.
Internalize Strings Internalize Strings Moves strings from a resource bundle into the form and remove the strings from the resource bundle.
Generate Java Code Generate Java Code Generates the Java code for the active form. Usually it's not necessary to use this command because when you save a form, the Java code will be also generated.
 
Window menu
Activate Designer Activates the Design view.
Activate Structure Activate Structure Activates the Structure view.
Activate Properties Activate Properties Activates the Properties view.
Activate Bindings Activate Bindings Activates the Bindings view. By default, the Bindings view is not visible.
Activate Error Log Activate Error Log Activates the Error Log view. By default, the Error Log view is not visible. It automatically appears if an error occurs.
Next Form Activates the next form.
Previous Form Activates the previous form.
Preferences Opens the Preferences dialog. Mac: this item is in the JFormDesigner application menu.
 
Help menu
Help Contents Help Contents Displays help topics.
What's New Displays what's new in the current release.
Tip of the Day Displays a list of interesting productivity features.
Register Activates your license.
License Displays information about your license.
Check for Updates Checks whether a newer version of JFormDesigner is available.
About Displays information about JFormDesigner and the system properties. Mac: this item is in the JFormDesigner application menu.

Context menus

Context menus appear when you're right-click on a particular component or control.

Design view context menu: Properties view context menu:
Context Menu Context Menu