Documentation

NetBeans plug-in

This plug-in integrates JFormDesigner into NetBeans.

Benefits

Using this plug-in has following benefits compared to JFormDesigner stand-alone edition:

  • Fully integrated as editor for JFormDesigner .jfd files. Create and design forms within NetBeans. No need to switch between applications.
  • Uses the source folders and classpath of the current NetBeans project. No need to specify them twice.
  • The Java code generator updates the .java file in-memory on each change in the designer. You can design forms and edit its source code without the need to save them (as necessary when using JFormDesigner stand-alone edition).
  • Folding and guarding of generated GUI code in Java editor.
  • Go to event handler method in Java editor.
  • Two-way synchronization of localized strings in designer and in properties file editors. Changing localized strings in the designer immediately updates the .properties file in-memory and changing the .properties file updates the designer.
  • Automatically add needed libraries (JGoodies Forms, TableLayout, etc) to the project.
  • Integrated with NetBeans's Version Control Systems.
  • Integrated into refactoring: Copy, rename, move or delete .jfd files when coping, renaming, moving or deleting .java files.

User interface

The screenshot below shows the NetBeans main window editing a JFormDesigner form.

NetBeans main window

A JFormDesigner editor consists of:

  • Toolbar: Located at top of the editor area.
  • Palette: Located at the left side.
  • Design View: Located at the center.
  • Structure View: Located at the lower left.
  • Properties View: Located at the right side.
  • Bindings View: Located below the Design view. This view is not visible by default. Click the Show Bindings View button () in the toolbar to make is visible.
  • Error Log View: Automatically opens on errors in a view at the bottom.

Creating new forms

You can create new forms using NetBeans's New File command. In the category Swing GUI Forms choose JFormDesigner Form and click Next to proceed.

New Form Dialog

Open forms for editing

You can open existing forms the same way as opening any other file in NetBeans. Locate it in NetBeans's Project view and double-click it.

Source / Design

The Source and Design toggle buttons in the editor toolbar enable you to switch from a JFormDesigner form editor to its Java editor and vice versa.

Source / Design

Convert NetBeans, IntelliJ IDEA and Abeille forms

You can convert existing NetBeans, IntelliJ IDEA and Abeille forms to JFormDesigner forms. Right-click on the form file (or any container) and select Tools > Convert to JFormDesigner Form.

Convert forms

When converting an IntelliJ IDEA form, JFormDesigner inserts its own generated GUI code into the existing Java class and removes IntelliJ IDEA's GUI code.

Options

JFormDesigner uses the term "Preferences" instead of NetBeans "Options". The JFormDesigner preferences are fully integrated into the NetBeans options dialog. Select Tools > Options from the menu to open it and then select the "JFormDesigner" page. See Preferences for details.

You can also set project specific options in the NetBeans project dialog. Select File > Project Properties from the menu to open it and then expand the node "JFormDesigner" in the tree. See Preferences for details.

Keyboard shortcuts

You can assign shortcut keys to some JFormDesigner commands in NetBeans keymap options. Select Tools > Options > Keymap to open it. Click on the Category column to sort key bindings by category name and scroll to the JFormDesigner category.

Unsupported features

Following features from other editions are not supported by the NetBeans plug-in:

  • Use look and feels in Design view.